Trigger problems...

Go down

Trigger problems...

Post  wilcthalacker on Sun Dec 26, 2010 11:23 am

I have one of the old rental Aks and so far its been a beast. but yesterday I rand into a problem that I realy have just been too lazy to fix yet. When the trigger is pulled it for some reason wont push the contact far enough back therefor not fireing. Any idea on how to fix this. PS as I said earlier I have yet to try anything.
avatar
wilcthalacker
SgtMaj
SgtMaj

Posts : 401
Join date : 2010-02-13
Age : 24
Location : Crestview/Mossyhead

View user profile

Back to top Go down

Re: Trigger problems...

Post  nobody on Sun Dec 26, 2010 11:43 am

i ran into the same problem with mine but on mine one of the wires leading to the contacts broke off
avatar
nobody
GySgt
GySgt

Posts : 173
Join date : 2010-03-24
Age : 23
Location : crestview

View user profile

Back to top Go down

Re: Trigger problems...

Post  comanche4 on Sun Dec 26, 2010 12:11 pm

Hi, I worked on a lot of the rental ak's before. Most of the time the contacts were to dirty to conduct, just had to clean them and put the gun back together. Put the gun's gearbox area next to your ear and pull the trigger and hold it down a few times. If you hear a cracking or huming sound it most likly the contacts are to dirty. If it makes no sound at all then you probably have some kind of wire problem.
avatar
comanche4
LCPL
LCPL

Posts : 51
Join date : 2010-02-05
Age : 27
Location : Crestview

View user profile

Back to top Go down

Re: Trigger problems...

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum